Warning: Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /homepages/14/d218565571/htdocs/wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
View Sidebar
Django, Eclipse y PyDev

Django, Eclipse y PyDev

17 noviembre 2010 8:47 pm2 comments

Warning: Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /homepages/14/d218565571/htdocs/wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524

En esta entrada veremos cómo configurar Eclipse para poder desarrollar aplicaciones web usando el framework Django, para ello instalaremos y cunfiguraremos PyDev, una IDE de python para Eclipse.

Primero instalaremos Django, para ello abrimos una terminal y hacemos checkout de la última versión de Django con Subversion

svn checkout http://code.djangoproject.com/svn/django/trunk django_src

Ya tenemos Django instalado, creemos ahora una carpeta para almacenar nuestros proyectos django, yo lo he hecho en:

mkdir ~/Documents/django_projects

Añadimos al path del sistema y al path de python el contenido que acabamos de instalar:

export PATH=$PATH:/Users/Javier/django_src/django/bin
export PYTHONPATH=$PYTHONPATH:/Users/Javier/django_src
export PYTHONPATH=$PYTHONPATH:/Users/Javier/Documents/django_projects

Para cercionarnos de que esto a funcionado podemos crear un proyecto de prueba y ver si corre:

django-admin.py startproject ~/Documents/django_projects/mi_proyecto
django-admin.py runserver --settings=~/Documents/django_projects/mi_proyecto.settings

Abrimos http://127.0.0.1:8000/ en un navegador y si vemos esto es que todo ha ido bien:

Screen shot 2010 11 17 at 21.00.01 300x154 Django, Eclipse y PyDev

Ya hemos completado el primer paso, tenemos Django funcionando en nuestro equipo, ahora configuraremos PyDev en Eclipse. Abrimos Ecplipse y nos vamos a Help -> Install New Software y añadimos esta dirección en el campo works widh “http://pydev.org/updates”, pulsamos en Add, esperamos a que refresque el campo de abajo para poder seleccionar PyDev, luego pulsamos en siguiente, y seguimos el wizard para completar la instalación. Reiniciamos Eclipse.

Ahora deberemos especificar dónde se encuentra el interprete de python en las preferencias Eclipse, para ello nos vamos a
Eclipse -> preferences -> PyDev -> Interpreter – Python, le damos a “new” y lo añadimos: ponemos Python en el nombre y “/usr/bin/python” en la ruta.

En el System PYTHONPATH añadiremos la ruta al directorio dónde se encuentra Django, para ello pulsamos en “New Folder” y seleccionamos el directorio “django_src” que creamos al instalar Django. Finalmente le damos a OK.

Ya podemos crear nuestros proyectos Django desde eclipse, para ello vamos a New Project -> PyDev -> PyDev Django project cómo directorio para el proyecto podemos elegir “~/Documents/django_projects” o cualquier otro, ya que Eclipse se encargará de añadir el nuevo proyecto al path automáticamente.

2 Comments


  • Warning: Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /homepages/14/d218565571/htdocs/wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
    Omar Mendoza

    Warning: Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /homepages/14/d218565571/htdocs/wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524

    Muchas gracias, excelente guía, saludos


  • Warning: Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /homepages/14/d218565571/htdocs/wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524
    Andrea

    Warning: Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /homepages/14/d218565571/htdocs/wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524

    Muchas gracias!!!!!!!

Leave a reply



Warning: Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /homepages/14/d218565571/htdocs/wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524

Warning: Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /homepages/14/d218565571/htdocs/wp-content/plugins/ultimate-google-analytics/ultimate_ga.php on line 524